ข้ามไปยังเนื้อหาหลัก
โทรหาเรา
  • สำหรับลูกค้าใน กรุงเทพฯ โทร.02-105-6194 (ภาษาอังกฤษ) ตั้งแต่ เวลา 04:00 น. – 21.00 น. ระหว่างวันจันทร์ ถึง ศุกร์02-105-6194
  • สำหรับลูกค้าทั่วประเทศไทย โทร. 060-002-4085 (ภาษาอังกฤษ) ตั้งแต่ เวลา 04:00 น. – 21.00 น. ระหว่างวันจันทร์ ถึง ศุกร์060 002 4085
หมายเลขโทรศัพท์และชั่วโมงทำงาน
ศูนย์ช่วยเหลือ

สำรวจแหล่งข้อมูลความช่วยเหลือออนไลน์ของเรา

ช่วยเหลือ

GoDaddy วิธีใช้

แก้ไขข้อผิดพลาดเกี่ยวกับปลั๊กอินของ WordPress

ทำตามขั้นตอนต่อไปนี้เพื่อแก้ไขข้อผิดพลาดเกี่ยวกับปลัํกอินใน WordPress

เตรียมเว็บไซต์ WordPress ของคุณเพื่อแก้ไขปัญหา:

  1. คุณควรสำรองข้อมูลเว็บไซต์ทุกครั้งก่อนแก้ไขปัญหาใดๆ
  2. ปิดใช้งานปลั๊กอินทั้งหมด โดยเฉพาะปลั๊กอินที่มีการแคชใดๆ
  3. ปิดใช้งาน WP_CACHE ถ้าเว็บไซต์บของคุณใช้อยู่

การทำความเข้าใจข้อผิดพลาด PHP ที่เกี่ยวกับ WordPress

ถ้าการแก้ไขปัญหาก่อนหน้าของคุณแสดงให้เห็นว่าเป็นข้อผิดพลาด PHP ให้ใช้ตารางต่อไปนี้ช่วยในการทำความเข้าใจข้อผิดพลาดนั้น


ประเภทของข้อผิดพลาด คำนิยามและขั้นตอนต่อไป
E_ERROR นี่เป็นข้อผิดพลาดร้ายแรงที่จะทำให้สคริปต์หยุดทำงาน โดยปกติแล้วจะมีสาเหตุมาจากการเรียกใช้งานออบเจ็กต์ที่ไม่มีอยู่ เช่น คลาสหรือฟังก์ชัน ซึ่งมักจะเกิดขึ้นบ่อยๆ กับเวอร์ชันที่เข้ากันไม่ได้ คุณควรอัพเดตเวอร์ชัน ธีม และปลั๊กอินของ WordPress
E_WARNING นี่เป็นคำเตือนในช่วงรันไทม์ที่ไม่ทำให้สคริปต์หยุดทำงาน เป็นปัญหาที่อาจเกิดขึ้นได้แต่ไม่หยุดการทำงานของ PHP บ่อยครั้งจะมีคำเตือนการยกเลิกใช้งาน ซึ่งจะระบุว่าโค้ดของคุณอาจใช้ PHP เวอร์ชันที่ตกรุ่นแล้วและต้องอัพเดต คำเตือนในบันทึกการใช้งาน PHP ของคุณไม่จำเป็นต้องเกี่ยวกับปัญหาที่คุณเผชิญอยู่
E_PARSE นี่เป็นข้อผิดพลาดในการวิเคราะห์เวลารวบรวมข้อมูล มักจะบ่งชี้ถึงข้อผิดพลาดทางไวยากรณ์ของ PHP เช่น ขาดเครื่องหมายอัฒภาค ; เครื่องหมายวงเล็บ () วงเล็บปีกกาเปิดหรือปิด {} หรือข้อผิดพลาดทางไวยากรณ์อื่นๆ จำนวนเท่าไรก็ได้ คุณควรตรวจทานไฟล์และบรรทัดที่ระบุในข้อความแสดงข้อผิดพลาดและหาข้อผิดพลาดทางไวยากรณ์ที่อาจเป็นไปได้
E_NOTICE นี่เป็นการแจ้งในช่วงรันไทม์อันเกิดจากข้อผิดพลาดของโค้ด ซึ่งเป็นข้อผิดพลาด PHP ทั่วไปที่ไม่ทำให้สคริปต์หยุดทำงาน ข้อผิดพลาดเหล่านี้บ่งชี้ว่าอาจมีปัญหากับโค้ด แต่อาจเป็นการทำงานปกติของสคริปต์ สาเหตุหนึ่งที่พบได้บ่อยคือการใช้ตัวแปร PHP ที่ไม่ได้กำหนด การแจ้งในบันทึกการใช้งาน PHP ของคุณไม่จำเป็นต้องเกี่ยวกับปัญหาที่คุณเผชิญอยู่

อัพเดตคอมโพเนนต์ของ WordPress

เมื่อเวอร์ชัน ธีม หรือปลั๊กอินของ WordPress อัพเดต อาจเป็นสาเหตุให้ขัดแย้งกับส่วนที่เหลือได้ การอัพเดตคอมโพเนนต์ทั้งหมดของ WordPress อาจทำให้เว็บไซต์ของคุณกลับมาเป็นปกติ

อัพเดตรายการต่อไปนี้ให้เป็นเวอร์ชันล่าสุด:

ขั้นตอนที่เกี่ยวข้อง

ข้อมูลเพิ่มเติม